MealSuite Support Notification- Core Tray Tickets

Incident Report for MealSuite

Resolved

The technical teams at MealSuite have successfully addressed and resolved all previously reported issues that were causing difficulties in generating reports within our Core application. As a result of their efforts, the reporting functionality is now fully operational and performing as expected.
Posted Jan 12, 2026 - 17:07 CST

Investigating

The MealSuite technical teams are investigating reports of the inability to generate reports within our Core application. This may impact your ability to access Core, as well as generate information in our Touch and POS applications.

We will continue to provide you updates as we progress through the investigation.
Posted Jan 12, 2026 - 15:17 CST
This incident affected: Touch and Point of Sale (MealSuite Touch, MealSuite Point of Sale) and Core System (MealSuite).