Our technical team has identified and resolved the issue that was preventing access to the MealSuite Core, Touch, and POS applications within the Synergy Database.
We appreciate your patience while we worked to resolve this matter. If you are still experiencing any issues, please don’t hesitate to contact us at support@mealsuite.com.
Posted May 13, 2025 - 12:28 CDT
Update
We are continuing to investigate this issue.
Posted May 13, 2025 - 12:28 CDT
Investigating
Date: May 13, 2025
Time: 11:45am CST
The MealSuite technical teams are investigating reports of the inability to access our MealSuite Core application in our Synergy Database. This may impact your ability to access Core, as well as generate information in our Touch and POS applications.
Posted May 13, 2025 - 11:45 CDT
This incident affected: Touch and Point of Sale (MealSuite Touch, MealSuite Point of Sale) and Core System (MealSuite).